Cringe

cringe

Other urls found in this thread:

medium.com/learning-new-stuff/survival-guide-for-junior-developers-d35371dd0818
twitter.com/SFWRedditImages

We're cringing at the color scheme right?

Also:
>}else{
YIKES

Nothing wrong with if else statements, what the fuck are you on about?

no need for else

the function body can be written as
return (statement);

And what's wrong with using it? Oh, the program is now 20 bytes larger. WOW!

cringe comments

cringe

i am a faggot

the dubs of truth

but then what would it return if one of those parameters are false?

new to programming here pls no bully

t. Siddharth

just type return false, no need for else
or this or not make a function for that at all

False.

That's the nature of all those '&&'s; they would return true and false anyway.

Indentation. He would prefer
if.(...) {
}
else {

}

> he doesn't /ask, not, demystify, visualize and chase/

I love that theme. You're a piece of shit for thinking it's cringe worthy

>shitposting so poorly into the night that you need to use the tomorrow color scheme
cringe

It is
>muh edgy as-dark-as-my-soul theme
>I live in a dark basement without sunlight and do not turn on the lights, bright themes blind me

It's fucking garbage you hipster millennial fudge packer

>using Yotsuba B
>burning your cornea with that bright blue
>not using comfy eye-friendly Tomorrow

cringe

>he doesn't know that black text on white is actually better for eyes because white text causes the rays to cross causing eye strain
thats just... cringe

>>burning your cornea with that bright blue
>He sits in a dark room with no lights save his monitor
Cringe

>oblique instead of true italics
eew

i have no idea what 2 think or who's recommending what themes

correct me if im wrong, but is there really any need for an else statement if youre returning something in the conditional, cant you just do
function willYouSucceed(ask, note, demystify, visualize, chase) {
if (ask && note && demystify && visualize && chase) {return true;}
return false;
}
can't you also just
function willYouSucceed(ask, note, demystify, visualize, chase) {
return ask && note && demystify && visualize && chase; }

>2
cringe

>} else {
Cringe indeed.

Correct.

>not solarising everything

just end it all, there's no saving you

I love that you nerds are so intense about color schemes.

i can understand how everyone has a colorscheme preference but i dont know how anyone can use solarized themes. it looks hideous

fuck off nerds you probably didn't even read OP

Solarized is a meme theme for idiots who think that using a """""""scientifically-designed""""""" colorscheme will make them better programmers

//the only acceptable way to do it
function willYouSucceed(ask, note, demystify, visualize, chase) {
return (ask && note && demystify && visualize && chase);
}

You know when you have the time in your evening to tell a whole bunch of retards that what they are doing needs to stop? This is that moment in my evening.

How fucking autistic do you shut-ins have to be to cringe at something so trivial and petty? What he wrote is easily readable, and an optimising compiler would simplify that anyways. Code is meant to be read 80% of the times and written 20% of the time. Try harder autists

yeah this isn't particularly legible. Logic for something this... uh... logical.. should be AS clear as possible.

>Caring about program size

also this is javascript, your return value will not be a true or false it'll be false or something truthy. e.g. if _ask_ is defined it'll return the value of _ask_ as is.

// correct way to do this in one line
function willYouSucceed(ask, note, demystify, visualize, chase) {
return !!(ask && note && demystify && visualize && chase);
}
//emphasis on the double exclamation
//explicit coercion to a boolean value
//if you don't understand what I mean you-don't-know-js :^P

otherwise you'll get something like
let a = willYouSucceed("I", "wonder", "what", "this", "returns");
a; // "I"

Do you want your Hello World program to be 500 KiB? Because that's how you get you Hello World program to be 500 KiB.

Statically-typed languages are bullshit

I don't argue about things like that until the beer fridge gets empty

>logic operator returns int
why is this allowed?

if (...)
{
(...)
}
else
{
(...)
}


the correct way

let hey_retard = true;
let message_for_u = "stop whining";
console.log (hey_retard && message_for_u) // stop whining

Programmers, generally-speaking, have got to be the most narcissistic, autistic cunts in the world. Especially the le web dev and le mobil dev ones. The amount of times I've seen these cunts liken themselves to wizards and the master engineer type shit is painful.

I dunno I spend most of my time on Sup Forums and there's a good deal more humility borderline self-flagellation in this community.

like when 9 of 10 threads are about some obscure topic you know nothing about you kinda have to put your ego on hold and acknowledge the vast amounts of skills and techniques you have no bearing in.

does it really matter after you compile it?

On most architectures, the if statement will compile to a branch. If you just return the value, you save that step. But you still incur a cost for having all that in a separate function.

>cringeeeee bro ugh cringgggggeeed /r cringe so hard there brah

Flip off.

...

I use it just because I think it looks nice. I didn't even know it was """"""""scientifically""""""""""" """"""""""""""""""engineered"""""""""""""".

>he doesn't use Burichan for that comfy old-timey feel

Fuck off you cunt

You'd need to use Boolean(statement) in JS.

OP is a faggot as usual and here's the article.
medium.com/learning-new-stuff/survival-guide-for-junior-developers-d35371dd0818

>not using custom fucking theme to suit your needs and desktop style

...

REEEEEEEEEEEEEEEEEEEEEEEEE

Literally disgusting

if (x = true) {
return doThis(thing);
} else return false;

>:^P
kill yourself

return(1)
17:56:28.411 SyntaxError: return not in function

I see this crap relatively often and it annoys me every time

//invert the variable
if(some_variable) {
some_variable = false;
}
else {
some_variable = true;
}

git gud just returning the conjunction of booleans is more readable than creating a useless man-in-the-middle structure. I bet you two like using break statements in infinite loops.

is it bad if i comment almost all of my code, will people think im a baby programmer (i am but i don't want them to know....)

>trying to shit on the One True Brace Style
kys

What color scheme?

some_variable = !some_variable
Better?

gruvbox, specifially "gruvbox (Dark) (Hard)" in the package I installed.

that's how i do it at least

Thanks

Yes, thank you.

private void backtrackAll() {
cptr++;
if(this.assignment.size() == this.reseau.getVarNumber()){
this.solutions.add(this.assignment.clone());
return;
}

String x = chooseVar();
ArrayList domain = sort(reseau.getDom(x));
for(int i = 0 ; i < domain.size() ; i++){
assignment.put(x, domain.get(i));
if(this.consistent(x)) {
this.backtrackAll();
}
this.assignment.remove(x);
}
return;
}

This grinds my gears

>he doesn't use futaba for obligatory for maximum readability.

Futaba uses a serif font. Serif fonts are good for printed text but much less so onscreen.

it's also not going to return what you expect it to, e.g. a boolean value.

And is it really more readable? Than an if ( this ) true, else false ? More lines or not the logic there is obvious.

in haskell, this is just
willYouSucceed = and

but the post background is blue
blue is a calming color, the exact opposite effect of red

>Nothing wrong if...
the brackets and semicolons are managed by the IDE and everybody uses this IDE right then there is nothing wrong. The IDE must also be written in a functional language and tested for at last 4 years before used in actual production.

and this is why Haskell isn't actually used
some amount of verbosity is good

willYouSucceed xs@[ask, note, demistify, visualize, chase] = and xs

function willYouSucceed(ask, note, demystify, visualize, chase) {
var success = ask && note && demystify && visualize && chace;
return success;
}

Oops, there is an undeclared 'chace'.

this insn't type safe, you should just using 5 parameters or an homogenous tuple

that's why you implement fuzzy variable matching in your compiler :)

If javascript were a nice puppy that var would get optimized out. No idea if it does

You can just
return ask && note && demystify && visualize && chase;

Yes they will; your code is so overcommented it reads like a programming tutorial.

Think a bit harder about variable names. lowerBoundary is a decent name, so you don't need a comment saying "lower limit". tempDummyBool, on the other hand, is a shit name - something like useRandomInput would eliminate the need for a few more comments.

Most of your other comments are completely redundant; you shouldn't be trying to teach people C++, you should be telling them about why you're doing things. The only comments I'd consider keeping would be the ones on mersenne twister.

10 rubies have been deposited into your windows store account

yeah but he wants a var in there
and if you want what I think you want then you should:
return !!(ask && note && demystify && visualize && chase);

Yes, but shit looks autistic yo.

>I like using Python, but I'm being forced to use Java, so instead of actually writing Java, I'm going to be a big fucking baby and write Java that looks like Python

Is there a reason to cast-to-bool in javascript?
I thought it's redundant.

Is casting to boolean really necessary in javascript? What could happen if you disregard it?

if any of them is falsey it should return false, as expected
If all things are truthy it will return the last evaluated term (chase), so you cast to bool to make sure it returns true instead

I just learned something new on Sup Forums.
Thanks.