How do you get these two PCs to communicate with each other if they have the IP addresses 192.168.10.5 (PC0) and 192...

How do you get these two PCs to communicate with each other if they have the IP addresses 192.168.10.5 (PC0) and 192.168.20.5 (PC1)?

PC0 is in Vlan10, and PC1 is in Vlan20, and I've added the IP address 192.168.10.1 255.255.255.0 in "interface vlan 10" and I've added the IP address 192.168.20.1 255.255.255.0 in "interface vlan 20", but they still won't ping each other. What else do I need to do?

Attached: 1499259396867.png (240x215, 9K)

Other urls found in this thread:

cisco.com/c/en/us/support/docs/lan-switching/inter-vlan-routing/41860-howto-L3-intervlanrouting.html
twitter.com/NSFWRedditGif

Is it a layer 3 switch? if it's not, how can it route between VLANs?

Did you enable iprouting?

To follow up, since that is a 2960, you'd need to enable RoS (Router on a stick) methodology to get the VLANs to communicate.

I thought you don't need a router for RoS if you use SVI?

How do I enable iprouting? ipv4 unicast-routing?

You cannot do routing on 2960. The SVI is to connect to it via SSH.

You need to use a 3xxx series switch and enable ip routing with #ip routing. Then configure the switch interfaces with IP addresses.

Else use router on a stick or two switches with switches connecting into router

So if I use a 3xxx switch, all I have to do is

192.168.10.1 < interface vlan 10
192.168.20.1 < interface vlan 20
192.168.10.5 < pc0
192.168.20.5 < pc1
ip routing

and that's it?

No shutdown

I always write interface range f0/1-24 and then "no shutdown" so I don't forget about it later, I know it's not a good idea but it's just packet tracer

Gay OP, you need to configure physical interfaces with IP addresses as well.

#ip routing (to enable ip routing globally)

#Int fa0/12
#no switchport
#ip add 192.168.10.2 255.....
#no shut

int vlan 10
#ip add 192.168.10.1 255.....


on pc
configure ip

I've configured the IPs on the PCs,

Why IP address 192.168.10.2? Fa0/12 is the port connected to PC0?

those ip addresses are not on the same network, they do not know where each other are, just that they are on a different network

they want to send data to their default gateway due to it being an unknown destination

10.2 will be the gateway for your pc. 10.1 is for for the switch to route between the vlans. Or you can use 10.1 on the physical interface and 10.2 for the int vlan 10.

time to read more theory OP. None of this will make sense without it.

cisco.com/c/en/us/support/docs/lan-switching/inter-vlan-routing/41860-howto-L3-intervlanrouting.html

applied on the router
>
>interface FastEthernet0/0.10
>>encapsulation dot1Q 10
>>ip address 192.168.10.1 255.255.255.0
>
>interface FastEthernet0/0.20
>>encapsulation dot1Q 20
>>ip address 192.168.20.1 255.255.255.0
>
>no shut (outbound router int)

Attached: derpderp.jpg (445x453, 17K)

If you just want to make them communicate, you could try making the netmask /19 or less and the ips would be able to communicate (they'd then both be in the 192.168.0.0/19 network).

Only drawback is they would no longer be in separate vlans and you'd have to configure your switch so that each port is in the same vlan.

Ah okay. So the interface vlan x needs their own IP address, and the physical ports on the switch needs the gateway address for that vlan's IP address, including the PC that's meant to use it.

this makes sense, so port fa0/12 is connected to PC0?

What about native vlans? If I add 3 more switches. Switch1 for PC0, Switch1 connects to Switch2, Switch2 connects to Switch3, Switch3 connects to PC1 and I add a native vlan called 150.

I'd have to enable trunking and add the native vlan 150, and that's it? I wouldn't have to add vlan 10 and vlan 20?

I know what router on stick is, but I read about layer 3 and wanted to try it. It seems easier, and less troublesome

As mentioned before, use a 3k switch that can route.

PC1:
-------
IP: 192.168.10.5
Mask: 255.255.255.0
GW: 192.168.10.1

PC2:
-------
IP: 192.168.20.5
Mask: 255.255.255.0
GW: 192.168.20.1


Switch:
----------

ip routing

vlan 10
vlan 20

interface vlan 10
ip address 192.168.10.1 255.255.255.0
no shut

interface vlan 20
ip address 192.168.20.1 255.255.255.0
no shut

interface fa0/10
switchport mode access
switchport access vlan 10
no shut

interface fa0/20
switchport mode access
switchport access vlan 20
no shutdown

a router is an L3 device

Attached: 7ca32b982cbc098100446d7d4678ab19.jpg (320x320, 11K)

yeah, you could just disable vlans altogether and use the native vlan as a purely layer 2 switch.

If that were the case I don't think you would need trunking anymore either.

I haven't used cisco devices in a while though, so all my advice may be garbage. No harm to just try it though.

>a switch is a L2 device: mac address
>a router is a L3 device: ip address
learn the difference then use devices that can do both

i really dont get what this kid is trying to do ?