What's the most Pajeet programming thing you've ever see done?

what's the most Pajeet programming thing you've ever see done?
>mfw one Pajeet programmer removed the extra line breaks in my C code so that it would run faster

Other urls found in this thread:

en.wikipedia.org/wiki/XOR_swap_algorithm
twitter.com/SFWRedditGifs

I first read this as if he removed the break; statements which is something I have (not) seen.

I made an Android app.

Sorry I'm not OP forgot to remove my trip.

I was a website once made by an actual rakesh who allowed to post comments containing xss code

saw*

>mfw I found out that Pajeet is not even an Indian name

electron application modifies its own HTML and uses it as a database

>trip

the fuck? what would be the point?

he didn't know databases

My boss said get busy pajeet to an indian, named pajeet, over voice chat.

I'm a professional PHP developer.

...

if x > 5 then
isOn = true
else
isOn = false
endif

I don't comment my code

This is the reason why the world is still at war. Let's fix this

isOn = x > 5

lol

>mfw I found out that Britbong is not even an English name

>mfw one pajeet insistingly pushes classes without getter setter methods
>mfw I have to change the whole code when there must be special treatments for getter/setter of specific variables

FUCKING PAJEET PUT GETTER SETTERS THE COMPILER ALREADY INLINES THEM IF IT'S SIMPLY GET AND SET RRRRRRRRREEEEE

Dev was presumably trying to build a TiddlyWiki, but with more electrons

does this work in bash?

>using java
we all know who the true pajeet is here son

it's c++, fucking faggot. if java is the only language you know that has oop paradigms, you are the indian beauty.

>using getter/setters in C++
>calling me a pajeet
kill yourself kiddo

...

w-whats better?

there was this one pajeet that made google panda algorithm.

>in openjdk
Really? wow

he's just meming. like a classical faggot. if you're going with oop paradigm, you will need getters/setters for specific access patterns on variables. new keywords like mutable, override etc. will especially be good for that purpose.

I made a website for 60 dollars per hour.

In pure html.

I still get asked to do updates sometimes. For 60 dollars per hour.

I can code now and would like to replace the website with something real. But I'm not sure if that would make my client happy. So I just leave it be.

My man.

Was there even any CSS? Was all styling inline?

They probably make more than you so they didn't bother to shop around.

Nothing tables cant fix.

Mostly inline. I just looked at the source code the only thing in a style.css file is the text markup.

I see I defined 7 paragraph tags and 7 heading tags.

JUST

Writing getters and setters.

Null terminate a single byte field. Not the first time this happened, I had put a giant comment above this line telling the pajeets that this field was not to be null terminated because it would corrupt the database (this was low level record handling code in a realtime database). It didn't slow the diapered fuckers down even a bit. I eventually wrote a script for the nightly build that checked this piece of the ~50MLOC codebase and aborted if it had been changed, which helped prevent our customers data from getting trashed.

only a pajeet would not write getters and setters. not everyone is programming in their basement, kiddo. some people actually program in teams.

Glorious See Sharp.

bool isOn = x > 5 == true ? true : false

He couldn't understand the difference between passing by value and passing by reference.
I saved a lot of RAM that day.

glorious js
isOn=x>5

But can it do this?

bool notEmptySpaceOrNull = (!string.IsNullOrWhiteSpace(randomString)) ? true : false

Getters and Setters for all private fields is just stupid.
It breaks encapsulation for no fucking reason.
Might as well declare them public.

And don't go on about changing the code inside getters and setters later.
If you do, then they don't get or set fields anymore, so their names are a lie.
Chances are if you change a getter from reading a field to computing something,
you should give it a proper name, rather than GetXXX.
When one reads Object.GetXXX() one expects that it's fast and idempotent, as in it just reads a field from the object.
If you later change it to do something complex, possibly non-idempotent, you are just asking for trouble.

Just make it a normal fucking method with a reasonable name which reflects the high level objective of reading/writing that field.
Using normal method names does not carry all the assumptions using GetXXX and SetXXX does.

var notEmptySpaceOrNull = (!randomString && [0, NaN, false, undefined].indexOf(randomString) > -1) ? true : false

forgot to link

Holy shit

How long you been doing this shit for, famamamalama?

>mfw I found out that Erdoroach is not even a Turkish name

But it wouldnt?

The compiler would remove all line breaks and white space, along with comments. So there is literally no point in deleting extra line breaks, right? Or am i retarded?

...

It may make the build a bit faster.
But that's probably not even measurable.

I do entry-level web dev for a living

You're right and yet still a retard.

Found the pajeet. Are you fucking serious? Have you ever heard about compiling?

Wouldn't minifying your code be good for embedded development?

No.

Guess what just hit my Desk.

GETXXX IS OPTIMIZED BY THE COMPILER TO BE INLINE IF IT'S A SIMPLE GET OPERATION

what part of it can't you understand?

if you have a data structure to be encapsulated, use a fucking struct. OOP paradigm starts with the classes. Nobody has to spend time to read your shitty code. directly accessing variables in classes is harmful for future reusability. Unless it's a const variable, you need to use that shit. OOP is supposed to be developer friendly, not performance based. Even so, a modern compiler always has to optimize a lot of oop stuff. There are keywords like const, constexpr, virtual, override, mutable, templates etc. to regulate your access patterns.


yeah by 0.000000001ns due to parser skipping spaces, pfff.

No idea.

MY HEAD

thanks to we now see the Sup Forumstards come out of the basement and say "ho ho look how smart I am, I can solve this insane pajeet problem!"

If you legitimately think that was the point behind those posts, then I think I can fairly assess that you're either delusional or just generally mentally incapacitated for the most part.

That's what's great about it: it's just supposed to kind of sound Indian.

OOP

IN

LOO

Conditional statement fag.

One guy I've worked with, was writing an AI for homing missiles in a mobile game. Pretty easy stuff, just activate, find a closest enemy and fly there.
He made a method getClosestEnemy that sorted the list of all enemies in the level by the Euclidean distance to the player: sqrt(x^2 + y^2).
For some reason, he didn't store that closest enemy in a variable. For some reason, he was asking for the closest enemy 6 times during the lock-on. Each frame. Even after the target was locked.
Each fired missile, each frame, sorted an array of each enemy, calculating the Euclidean distance to the player.
In a mobile game. This shit probably would go unnoticed if it wasn't a mobile game.

what the fuck

That idiot! He doesn't even need to take the sqrt if he just wanted to sort the list. he could've just skipped the most expensive operation in the entire algorithm.

Yes, it's a general rule, usually you never need sqrt. Only the square of the distance.

i really hope this is bait

Yep. Well, it was a year ago and I lied - it wasn't "getClosestEnemy", it would be too easy to understand. He called it "getFirstEnemyInList".
And this logic (that didn't even work properly), I didn't even try to comprehend, just scrapped this shit completely and rewrote it.

>4 spaces indentation
Why is it a surprise?

This is just a condense statement. Literally does nothing to improve speed. If anything it decreases readability.

Most languages have support for true false values based on integers.

IsOn = (x > 5)

Would be more acceptable.

$user_id = $_COOKIE['user_id'];
$logged_in = $user_id > 0;

It's a clusterfuck of an indentation. There's no indentation, dude just had seizure on the tab/space/enter key.
Also
>return true;}
>this.isInVisualContact ()

Log

this is production code?

• conditionals nested 7 layers deep

en.wikipedia.org/wiki/XOR_swap_algorithm

It's code for some stupid college project.

Almost, it didn't pass my review.
University, but yeah. And not so stupid, we've made a pretty cool game.

Depends on the situation.
Very often, you would not use setters/getters.
You would have actions where you mutate variables rather than just changing the variables.

I have written many classes where the protected variables is hidden because they should not matter to the user.
In classes where the data does matter to the user, you might as well expose it, unless it is important to check for errors or do something else when the values change.

The idea of object oriented code is that you should design objects which do things.

That shouldn't translate into an arbitrary number of setters and getters.

literally, the PHP facebook group

I was working on a website that had been initially developed cheaply in India. Rather than use an actual version control system, Pajeet would copy+paste sections of PHP code into block comments and write what he changed. Each file was 10,000+ lines long of almost entirely commented out code

...

Ajeet is anyway