/cisco/ Thread

I though I'd lay down some cisco from what I've learned the past couple of months.

For instance, this all that goes into configuring a switch.
Switch> enable
Switch# configure terminal
Switch (config)# hostname S1
S1 (config)# line console
S1 (config-line)# password cisco
S1 (config-line)# login
S1# exit
S1> enable
S1# config terminal
S1 (config)# enable secret class
S1 (confg)# banner motd "Welcome to the Sup Forums /cisco/ thread Switch."
S1 (config)# interface vlan 1
S1 (config-if)# 192.168.1.253 255.255.255.0
S1 (config-if)# no shutdown
S1# exit
S1>enable
S1# copy running-config startup-config
S1# reload

Other urls found in this thread:

ss64.com/nt/
ccna5.net/
netacad.com/about-networking-academy/packet-tracer/
computernetworkingnotes.com/cisco/ccna-study-guide/
sharontools.com/online-lab/
beaglenetworks.net/post/42707829171/star-wars-traceroute
ccnav6.com/
twitter.com/AnonBabble

Completely forgot this command after "configure terminal"

S1 (config)# service password-encryption

Of course if you want to verify the configurations you would use this command

S1# show running-config

and to see what's in the non-volatile RAM (NVRAM), you'd need to do something like

S1$ dir nvram:

wow OP, congrats on Mod 1.

How about some VRFs, route-maps, eBGP and QOS?

Whoops, that S1$ was supposed to be S1# on the prompt.

At any rate, let's move on to Router configuration.

Router> enable
Router# configure terminal
Router (config)# hostname R1
R1 (config)# line console 0
R1 (config-line)# password cisco
R1 (config-line)# login
R1# exit
R1> enable
R1# configure terminal
R1 (config)# enable secret class
R1 (config)# service password-encryption
R1 (config)# banner motd "Welcome to the Sup Forums /cisco/ thread Router."
R1 (config)# interface gigabitethernet 0/0
R1 (config-if)# ip address 192.168.0.1 255.255.255.0
R1 (config-if)# description "LAN connection to S1"
R1 (config-if)# no shutdown
R1 (config-if)# end
R1# ping 192.168.10.10
R1# show interfaces
R1# show interface serial 0/0/0
R1# show interface gigabitethethernet 0/0
R1# show ip interface brief
R1# show ip route
R1# copy running-config startup-config
R1# reload

There's also alot more that goes into configuring a switch.

>Spanning Tree
S1(config)# spanning-tree mode rpvst
S1(config)#spanning-tree vlan 1 priority 0
S1(config)#spanning-tree portfast default
S1(config)#spanning-tree portfast bpduguard default

>Giving ports access and securing them
>Best practice, don't use VLAN1, but since you used it, heres an example.

S1(config)#int range g1/0/1-48
S1(config-if-range)#desc
S1(config-if-range)#switchport mode access
S1(config-if-range)#switchport port-security
S1(config-if-range)#switchport port-security max 1
S1(config-if-range)#switchport port-security mac sticky
S1(config-if-range)#switchport port-security violation shutdown

>Also setup DHCP.

S1(config)#ip dhcp excluded-addresses 192.168.1.253
S1(config)#ip dhcp pool VLAN-1
S1(dhcp-config)#network 192.168.1.0 255.255.255.0
S1(dhcp-config)#default-router 192.168.1.253
S1(dhcp-config)#dns-server 8.8.8.8 8.8.8.4

That's all that goes into a switch? Hahahaha

OP if you were using different VLAN, you would have to

S1(config-if-range)#switchport access vlan

you

Lol, learned that shit before I was old enough to be on this site

>he doesn't manually configure his switch from a CLI.
what are you, consumer faggot?

OP at best has achieved CCNA,
I live in Putty as a sysadmin you spanner.

Not OP but we use VRFs on our N9K cores at work, an engineer more skilled than my current self set them up, can you help me understand exactly what a VRF is or does? Best I can understand it's like a context but what exactly does that mean? All I know is that a context, when talking about like ASA, is just basically a virtual instance of the firewall...
There isn't much we set either, we do set QoS values for VOIP traffic though and prioritize that. Nothing else really special other than bpduguard and port security max of like 2 I think. And obviously set the proper VLAN assuming it's trunked down from the core. (We use collapsed core not true 3 layer, we aren't big enough)

Is that all there is for CCNA? I don't even have my CCENT, just a 2 year degree and everyone says CCNA is really hard even. I want to go up to CCIE but I don't know where to even start.

All day I wait for Cisco threads like this.

>putty
install gentoo

Maybe you can look in to TACACS next and LDAP from AD, that's always helpful when logging. Like I said I care for a large site of a multinational company and spend most of my time in Putty now because we're expanding like fuck and there's access switches popping up all over the shop but my next big project is a hyper converged SAN.

Lol i bet you're going to BdeB

>woah look guys I'm halfway through CCNA 1 and I can configure switches better make a thread on Sup Forums

Judging by your posts you definitely have the exp for CCNA, if anything the exam terminology catches many out but you seem fine with config.. if not a little naïve lol, a lot can be done on them.

>copy run start

Nice.

This is new stuff for me. I just wish when Cisco devloped IOS, they would have borrowed more commands from Linux, Unix, or DOS. I mean, there a TON of old DOS commands.

ss64.com/nt/

I'm
those.
Hm. Yes, I went through my 2 years of community college fast (actually 3 years but I co-oped for a year of that) I'm at almost 4 years of exp. in the field at this point, and am the "cisco guy" at work. Also the phone guy which I learned about 95% of all I know about VOIP from work, we only barely touched on it at school. I want to work somewhere bigger, though, I hate being "the x guy". It's just intimidating and hard to find the motivation to kick myself in the ass and get moving. The CCIE we had in to help us configure everything is pretty smart, I admire his skill set.
I already configured a switch to talk back to a Windows NPS for username authentication. So instead of logging in with a local username and password, I'm logging in with my AD credentials.

Only thing that's stopping me from deploying this is that I can't find a way to either not use an enable secret (go straight into enable mode) or use AD credentials' password for the enable secret. Which I understand shouldn't be possible since it's a separate phrase. SSH needs the enable secret if I'm not mistaken but I don't want to give this out to co-ops, but they would like the co-ops to be able to log in and do some troubleshooting and now they are not allowed due to all the production devices running local credentials. Any idea how to resolve this as otherwise I have a working RADIUS login config.

Heck, most of the answers to the CCNA exams are online.

ccna5.net/

IOS was made before Linux existed....

VRFs are a really a simple concept. Image it simply as a separate instance of the routing table.

You have your global routing table, which is what you see changes in when you configure an interface with defaults.

VRFs create a separate routing table, only interfaces which are told they are part of the VRF would show up in that VRFs routing table. When an interface is part of a VRF, it will no longer take part in the global routing table.

This means that it will not be routing using that table, so all of the routes in the global table are invisible to it. It only sees the routes in it's table.

It's a really simple concept, here's a quick demo on a really simple Front-Door VRF.

R1(config)#ip vrf BASIC-VRF
R1(config)#router rip
R1(config-router)#address-family ipv4 vrf BASIC-VRF
R1(config-router-af)#version 2
R1(config-router-af)#no auto
R1(config-router-af)#network 10.0.0.0
R1(config)#interface g0/0
R1(config-if)#ip vrf forwarding BASIC-VRF
R1(config-if)#ip add 10.10.1.1 255.255.255.0

The cool thing is, using VRFs i could have multiple interfaces with the same IP address with no issue since they are in there own routing tables.

To show the routing table we just created

R1#show ip route vrf BASIC-VRF

Other useful stuff
R1#show ip protocols
R1#ping vrf BASIC-VRF

I did CCNA based college classes. It was pretty fun but I never got any certs.

I thought it was hard too... but I suck at programming too.

I dont know many who know about Cisco stuff. Feel like a lot just do programming and dont do any networking stuff

>enable instead of en
>configure terminal instead of conf t
>hostname S1 instead of host S1
>line console instead of line con
>password cisco instead of pass cisco
>banner motd instead of ban motd
>using " as a delimiter instead of #
>interface vlan1 instead of int vlan 1
>no shutdown instead of no shut
>copy running-config startup-config instead of copy run start
>reload instead of rel

Wtf OP it's like you don't even care about your keystrokes. You could have saved like 30 seconds of your life right there.

Lmao

You should get into that as you take Mods 2, 3 & 4 of CCNA, although I know they've changed alot and you actually learn QoS and eBGP in CCNA now, which I learned when I first started my CCNP, which I'm almost done with.

Hopefully you can get a job somewhere where you work with CCIEs, I've learned alot of cool tricks and commands from them. Be very wary though, if you're not a fan of show and debug commands, CCNP TSHOOT can be a bitch.

>S1# copy running-config startup-config
not
>S1# write mem

??!???

>S1#copy run start
not
>S1#del flash:

>S1# copy run start
not
>smashing the switch with a hammer

copy run sta

is what I use. It is the shortest form of

copy running-config startup-config

wr mem is the shortest form

right? I always try to use shorthand

en
conf t
int fa0/1
desc Printer 3rd Floor 3215 (or something)
sw mo acc
sw acc vlan (printer VLAN)
no shut

etc etc
sw mo tru
sw tru enc dot1q
sw tru all vlan add (list of vlans)

sh run
sh run | in dhcp

Actually my most used commands are:
ping (known address unknown port)
sh arp | in (that IP address)
sh mac add | in (that mac address or a fragment of it)
conf t
int (that interface)
shut
no shut

etc etc
wooo i know shorthand the interpreter does very well.
I learned the pipe command from our CCIE, there's
| include (something}
! filters output to include only lines that include a literal of what you typed
| section (something)
! filters output to a section of what you typed, for example section DHCP would show all DHCP config.
then exclude, begin, and a few others but I mostly use include, begin, section, and exclude.

IOS is a breddy cool thing. Wanna learn more about NXOS cause that looks even cooler.

not
>wr er
>rel
>y

actually it takes wr me

but write memory is deprecated (though still works on IOS but not sure about NXOS, think our CCIE had to setup an equivalence for us just for fun)

Thanks, user.

I'm actually trying to cram several chapters today because of finals this week because my community college has an accelerated version of CCNA that pushes two years of CCNA into one year. The really suck part is that it is evening classes, but the instructor is cool.

It's important I pass Mod 1 and Mod 2 before summer so I can take a security class this summer that is only offered once ever other year.

I've got a lot of stuff on my plate, although I wish we did more Packet Tracer exercises than reading.

I feel like I need to go back on a couple of chapters and clear my head on ARP and EIGRPsdfssdnlaweg and RIP

netacad.com/about-networking-academy/packet-tracer/

Another good site for CCNA study would probably be
computernetworkingnotes.com/cisco/ccna-study-guide/

Yeah we don't use "write memory"

We use "copy run sta"

Get into GNS3 if you plan on continuing, there's alot of features that are removed in packet tracer.

If you also plan on getting your CCIE get Cisco's VIRL or build a lab, up to you which one you do, they both cost money.

VIRL is $199 right now. Labs can cost 2k depending on what you get.
Just create an alias for it.

"alias exec wrmem copy running-config startup-config"
Piping is very useful, that was the first thing our CCNA instructor taught us. Along with the hotkeys to jump to start of line (Crtl-A) and end of line (Crtl-E)

>everything in default vlan

What the fuck am I reading?

Don't forget setting up VTP if you're a lazy fuck/actually work in a large network. I mean unless you like having to type the same 10 vlans on 50 switches instead of 1.

Very true, VTP is useful but I've also seen it cause lots of issues when admins forget to change a client switch from server mode.

fuck off OP

I don't want to lose my 100k/yr job

Yeah, if the rest of the world finds out how easy our jobs are we'll be screwed

Anyone actually work in networking here? Junior NetEng here at a small ISP

Cisco devices weren't even meant for manual configuration back in the 80s, they were supposed to pull the config (and firmware) from a tftp server.
Then they quickly threw a shitty CLI together at the last second

That's not the proper CCNA, but the Netacad CCNA exams.

Until you try to "sh"ow something on the interface config mode of the uplink that carries your ssh session.
Don't shoot from your hip. Take your time, think about your commands, especially on Cisco-style CLIs which put the new config immediatly into action instead of using committing. You're not saving much time, you might even waste a lot of time and money with outages related to quick-shooting.

You'd have a blast with Junos' CLI
Try it out here
sharontools.com/online-lab/


Remember to password-protect your VTP domain, else a new switch with a higher revision number enters and all your vlans are gone

SDN will take your job anyway

This is why I'm switching over to security.

VTP is not recommended for use and you should have software that can deploy configuration across all your switches with so why even bother with VTP?

>2017
>rip
I know you are just using it as an example but come on nigga

>manually entering "switchport access vlan" onto a port

With 802.1x switchport authentication and a RADIUS server you can automatically assign VLANs to ports and use MAC bypass for things like printers and have much more visibility as to what port is plugged into where.

A switch needs no configuration to work and you forgot the vty lines :)

how much can you expect to make with a fresh CCNA cert?

BPDUGuard is dumb because now you have to go in there and do things after users whine

If you use BPDUFilter in global mode the switch won't send BPDUs until it receives one, then it will start doing spanning tree on the port. Look it up, this is the 99% solution.

If you test for them they don't let you abbreviate

I got myself one ADSL cisco router 877w

I have managed to create wifi by MANY trial and error, what fucking cert/book manages that shit, i have looked through some WIFUND cert book and i didn't find jack shit in it

I found a how-to guide in less than 10 seconds of googling

i found 20 how-to guides, all of them different

also, i don't want how-to guide, i want specific book that teaches how to set adsl+wifi

adsl (or pppoe) is covered slightly in ccna, but wifi using cli i didn't find anywhere

If you want to learn about ADSL then go buy a book about WAN technologies
If you want to learn about WiFi go buy a book about WiFi

If you want to implement both on a Cisco router then use what you learned in those two books, apply your knowledge and go through the command listing on Cisco's website for reference. If you need someone to hold your hand you can google it.

Its like three lines of config unless you are doing wack shit, then its slightly more commands which you should know about if you understand the technologies. You don't need a book for that, you need reference material which is easily available online.

Genrally in the command exercises, they don't allow abbreviations. You can abbreviate in the packet tracers though.

I personally want to learn more about WiFi stuff too. I would especially like to figure out how to set up Wireshark to look at packets over wireless connections.

Out of curiosity, could Software Defined Radio (SDR) be used as a means to do packet sniffing for Wifi? I though I saw something on Hak5 about this topic.

It would be easier to run a Wi-Fi adapter in monitor /promiscuous mode.

Theoretically you could use an SDR but there is no software available to do all the encapsulation etc. You'd just see a raw layer 1 capture of the data.

>I have managed to create wifi by MANY trial and error, what fucking cert/book manages that shit, i have looked through some WIFUND cert book and i didn't find jack shit in it

Just get an actual Aironet and setup a vWLC. The GUI is actually half decent.

>I would especially like to figure out how to set up Wireshark to look at packets over wireless connections.
That is just setting up a SPAN port on the switch

So how would I convert that data to a higher layer? At least to a transport layer. Higher would be better.

Here's a geeky use of VRFs: beaglenetworks.net/post/42707829171/star-wars-traceroute

>giving a serious reply to an obviously ironic post

Did the "30 seconds of your life" part not tip you off?

Wait. Thera are still people on Sup Forums that aren't basement dwellers and actually have respectable jobs in networking?

Scary isn't it

Keep reading, you will learn more :)

I'm going for my CCNA now. It is really hard, not because of the detail of content, but because of how much there is. It's really interesting and I'd definitely recommend.

My day job is a web dev.
This cisco class what do in the evening.

We should have these kind of threads more often.
I'm currently enrolled in a Cisco class too and this is actually pretty motivating.

>>Use wr mem all the time at work ON ACTUAL SWITCHES and it works FINE

>>Use wr mem on the CCNA lab portion and it's incorrect because they want you to write the entire fucking thing out

LET'S MAKE THE CCNA A CLUSTERFUCK TO PASS SO WE JUST SELL OUR MORE EXPENSIVE MERAKI SHIT SINCE ITS ALL GUI AND COMPANIES DON'T WANT TO PAY A GUY WITH A CCNA WHAT HE'S ACTUALLY WORTH

I'm onto you, Cisco

Is wr mem just a replacement for copy run start?

>>>Use wr mem all the time at work ON ACTUAL SWITCHES and it works FINE
Why do you even write "mem" instead of just "wr"?

I have my second attempt of CCENT on Friday. Best ways for some last minute cramming?

This, in real life situations you always have to setup your devices as fast as possible to outspeed hackers who want to penetrate them!

Some Men Just Want to Watch the World Burn

>>My company buys all these expensive Meraki switches and cameras and firewalls from our vendor

>>It's my responsibility to manage them and do the setup so I see there's a CMNA certification for Meraki so naturally I want to take the certification class which is ONLY offered by Cisco themselves to their vendors. This is the actual certification class not that bullshit one that's available to the general public where they send you a free AP afterwards

>>Call up our vendor that we have given literally hundreds of thousands of dollars to asking if they can sign me up for the class

>>"Sorry you are the end-user and not our employee so we can't sign you up because that's breaching the trust we have with Cisco as a vendor"

Guess which vendor's contract isn't getting renewed?

That may explain why the CCNA Mod 1 course uses VLAN1 and why Cisco Systems CEO Chuck Robbins wants to MAGA.

Habit from when I was taught. WR works just fine and is the shortest, but wr mem is still a hell of a lot shorter than copy run start but if you use wr or wr mem on the cert lab it doesn't recognize the command

They're all online.

>copy run start instead of just "wr"
you are just as cancer as op.

I do network support in a company that installs networks in hotels. It's pretty basic

Why not both?

Packet tracer is a shit for making you login every time

Networking and information security student here.

Good thread. Lots of good information.

Studying for the ccna, do people get jobs with just the ccent? I'm in a soul sucking unrelated field and would like to jump ship as soon as I can.

I've been trying to study networking but I can't keep focused and I procrastinate. How do you bros do it? I have downloaded CBT Nuggets videos and bought a book but it's so dry without coursework

I'm going to college. It's fun and the expectations of other people keep me motivated.

I'm probably getting made redundant at the end of May, need my CCNA to get a better job. Have my CCENT in 2.5 weeks.

CCNA isn't super hard. Avoid tunnel vision and learn how to subnet super fast (write down cheat sheets before actually starting the exam) and it'll be a breeze. I'm re-certifying this year.

I was made redundant so I now get my college paid for, truly the best situation.

Plus I got 5 years of working in hotels so I can translate that experience to a new field.

I've already got my degree. I'll be getting a few thousand in severance pay, but I'd like to have something lined up so I can basically get told to fuck off on Friday and roll in to a new job on Monday. That way I can blow that severance pay on stupid shit I probably don't need but want.

Based. I wish I had worked on my degree before going into the workforce but 18 year old me was an idiot. But here I am.

Severance pay is great, I wish I had gotten a package but I'm happy with them classifying me as redundant instead of terming me, that's what's paying for my school. Additionally I got my annual bonus the week before so I guess that's similar to a severance package.

Good plan though user.

I literally graduate with a Bachelor's in Business with a concentration in Finance this month. God I wish I had gotten something technology related

>using proprietarry literally backdoored hardware on your networks

BSCS. My instructors pressed the idea that JAVA would be the future. (It wasn't.) My folks though I wasted my time since it took me 9 nears to get a job in the industry. Then I got a call last year from someone willing to hire me after all those years of going to job fairs and filling out job applications. I may be autistic, but sure as hell not Chris-Chan retarded. I managed to make enough money to go back to community college, take CCNA. Apparently, my state (Missouri) was willing to offer free education course for going back to school for IT/Help Desk. It should be noted that CCNA is not part of that program. I'm still glad I did CCNA instead of IT/HD especially since it was meant for folks who didn't go to college, get a BSCS, or still fiddle around with JavaScript while waiting for a callback.

Out of curiosity, does anyone have a resource for finding solutions to Packet Tracer exercises.

I wanted to go back to the Skills Integration Challenge (6.5.1.3) and rewrite my notes that I messed up.

bump

PACKET TRACKERS!

ccnav6.com/

>password protecting VTP
Changing the domain is going to be more effective. Net admins are the one kings of the one password everywhere assholes

missing logging synchronous
if we are talking about basics.