Okay Sup Forums:

Okay Sup Forums:

Which way of formatting is correct, and why is it the first one?

First one because only electrical engineers / retards program like the second one.

Literally this.

Top increases readability waaaay more.

second one because you're not fucking gay

>because you're not fucking gay

You can't even give me a reason as to why the first one is gay. No one who does it the second way can.

if(poster == op)
{
penis.setsize(tiny)
}

neither, only autists use braces on single statements

At least it's formatted the right way

Okay, you got me there. How about for multiple statements, then?

...

this will erect penis two times

>pissing away a whole line on a single brace which is unnecessary because you indented anyways
?

>responding to "what u like is gay" shitpost with a serious argument
like does the question in the op's really matter that much to you

who the fuck cares, just use both so you can ocdsnipe which of you coworkers are gay autismos and should be let go

if(tits.size() >= breastsizes::large) erect(&penis);

#include
#include

#define OP 1
#define FAGGET 1

int main(void)
{
if (OP == FAGGET) {
printf("kys fagget\n");
}

exit(EXIT_SUCCESS);
}

if tits == large:
penis.erect()
too easy OP

>space after if, it's not a function
>space between ) and {
>use tab, literally character designed for indentation

if(tits == large) {

}

Everything else is fucking horrible

no chest must be flat

>use tab, literally character designed for indentation

it should be poster.setPenisSize(TINY)

he's right though

eww...

this

holy shit this is ugly

Exactly. Wasting vertical space means you have tons of low density source files. I prefer to see as much of the code as possible.

Of course if you are there to score SLOCs you go for the space wasting solution.

this is not the 70's anymore grandpa.we dont have to work on small crt monitors,and we dont have to print out our code either,readability is most important.

if (tits == large) penis.erect();

Anyone up for a fight?

This kike is:

if(tits == large){ penis.erect(); }

>not writing your entire program on one line

if (tits == large) {
penis.erect();
}

I work for a national research laboratory writing code for one of the fastest supercomputers in the world.

(when (largep tits)
(erect penis))


:^)

if (condition) statement
condition ? true : false

if (tits == large) {
penis.erect(); }

dont lie

argonne mira
i-i'm just a student intern

Either brace placement is fine. The actual issue here is the lack of a space after the "if" keyword, which betrays the author's likely lack of understanding of the difference between a statement and a function.

>it's not a function
found the rube

This.

Unless your only knowledge of programming involves excel spreadsheets, it's not.

this

The second version is more optimal because it adds less lines to the source. Also, the second version is pretty much the de-facto. The first one is for retards who can't conceptualize what a block statement is.

The actual best answer?

if(tits == large) {penis.erect();}

>first half of post entirely sensible
>last line fucking retarded
You tried

>readability is most important.
I know. And air is not readable; it is contents free.

I know nothing about programming, absolutely nothing but isn't the second one more efficient to compile and run? With something like being even better than the other two?

GNU/Indent:
if (tits == large)
{
penis.erect();
}

>hur dur let me just add extra lines and white space for no reason

(tits == large)&&penis.erect

It makes literally no difference to the compiler. What matters in this is code readability.

First one make me feel good, second one makes me uncomfortable.

that means you're gay

this is acceptable

>Which way of formatting is correct, and why is it the first one?
trick question, the first one is not correct.

tits == large
? penis.Erect()
: throw new TitsTooSmallException();

this desu senpai

if (tits.largeNess >= TitsizeBoundaries::LARGE) {
serviceContainer.get().createErectionFor(penis);
}

if(tits==large){penis.erect();
}

$penis->erect() if $tits == $large;

...

if(poster == op)
{
setsize(penis, tiny)
}

Fixed that for you.

if (tits == large && penis.erect())

if[tits=large;peniserect[]]

penis.erect() unless tits != large;

The first has way more readability, but I prefer the second only because it is more compact when using if / else if / else.
After a while, the readability becomes second nature, and the second is prefered because of the look.

> actually forgetting the ;
Must be curryscript

>exit on the last line of int main

Neither.
if (tits == large)
{
penis.erect();
}

top for indians who get paid per line
the indentation makes things clear enough

if (tits == large)
penis.erect();
or optionally
if (tits == large) penis.erect();
Using brackets for single-line conditions is fucking stupid.

>Kernel style
While I personally don't like it, it's consistent at least

if (tits == large) { // notice the extra spaces
penis.erect();
}

if (tits.getSize() == titSizes.Large) {
penis.growGrowGrow();
}

You may or may not end up including more statements so better to use brackets just in case.

python is correct

> OOPfags will defend this

Ideal

don't bring getter methods into this, you degenerate

Is there a way to just bind the tab key to automatically put multiple spaces?

that's the WORST option

Why?

because it means you have commitment issues

I see no TitsFactory, trick question.

Tits == large is fucking stupid. What the fuck is large? What is tits? A fucking integer? That's not enough. Also what if the tits are larger than large?

Size is a property of tits. And how big "large" is should be defined in some kind of array so if your opinion about what large tits are change, they can easily be changed.

In fact, you could I would even use
serviceContainer.get().evaluateTitsize(tits, ITitSizeEvaluator.LARGE);


For maximum flexibility.

The next part is essential, because classes should have one responsibility. Don't separate functionality like that and you'll end up with a penis class with 200 methods that does logging, DB- and cache synchronisation and algebra.

However, if erectness is just a field of Penis, then just add a setter like "setErect(erect: bool)". Or in a good language, just use a property.

fucking this
tits == large ? penis.erect()

flat is right

Actually, the correct one is a superstate of both:
if(penis == feminine) {
{
post.shit();
}
}

I don't know of any language that has a ternary operator where this is valid syntax

if(poster instanceof op){
poster.setPenisSize(Sizes.tiny);
}

fixed

i am an EE and this triggered me

but the second one is better

It's consistent in its inconsistency?

Bottom is how men do it

You can do that in any editor more advanced than notepad

Second one is better. Prove me wrong.

javascript fags get out ree

the "C++ wizard" at my job codes like this
public
void
function (
int a,
int b,
char *c
) {
do_shit(a, b, c);
}

is he right?

OP = gay;
if(OP == gay){
mind.thought(dicks)
}else{
mouth.suck(cocks)
}

GNU C style is the best style.
if (tits == large)
set_penis_status (erect);

2nd in this case (one line)

1st everywhere else.